F-Spot Crashed on SuSE 10.1

Ever since this SuSE 10.1 installed, I could never once run F-Spot. I couldn’t remember what is the version of F-Spot that originally comes with SuSE 10.1 CDs, but even that one didn’t work. So, I upgraded it to 0.1.1 (the latest version at the time of writing is 0.2.2), but the same problem still remained. This is how it looks like when I run the program:

kenno@localhost:~> f-spot
Starting new FSpot server
XXXXX
System.ArgumentNullException: Argument cannot be null.
Parameter name: s
in System.Int32:Parse (System.String s)
in MetaItem:get_ValueAsInt ()
in FSpot.Database.Updater:Run (.Db database)
in Db:Init (System.String path, Boolean create_if_missing)
in FSpot.Core:.ctor ()
in FSpot.Driver:Main (System.String[] args)
XXXXX
Starting new FSpot server
Starting new FSpot server
Starting new FSpot server
Starting new FSpot server

On KDE desktop environment, there is also a very good native photo management application called digiKam which I have been using to organize my photos. Because of this less free time due to school related stuffs, getting the F-Spot running on my Linux box has been a low priority. Having said that, I never forget about it. Today, I just finished all my exams for this semester, and I decided to dig around in Google to look for the answer. Just as last time, there was no luck with Google. Then I tried to talk to the developers of F-Spot in the #f-spot. It was so hopeless still. It seemed no one in there was awake!

When I was about to give up on this program, I decided to give the last try at SuSE Community forum. I searched for "f-spot can't start", and found a few related threads, but most of them were just single post with no answers. However, I found this one which was very helpful. It turned out that the fix was the easiest one ever. All you have to do is to remove the old F-Spot db/configuration file in your home directory (~/.gnome2/f-spot/photos.db), restart F-Spot, and voilla, it runs like magic!

The next step is to find out how to compile F-Spot 0.2.2 to run on SuSE 10.1!

About these ads

2 thoughts on “F-Spot Crashed on SuSE 10.1

  1. Since I was mostly with KDE, I’ve used only digiKam. But I will give F-Spot a try when my Ubuntu 7.04 CD pack arrives at my door. I have requested the CD via ShipIt since the end of April and hope to get it soon.

    But anyway, I’ve learned another trick with F-Spot.

  2. I also use KDE as the desktop environment. Now, I’m running openSUSE 10.2 without f-spot. I don’t know what is its latest version either. But I think the later version of f-spot won’t cause any more problems.

    The more I run digiKam, the more I like it. It loads very fast since it’s a Qt app.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s