Fixed: /usr/lib/libdb-4.5.so: no version information available

After installing XEmacs, and ran it in terminal-mode, I got this error:

$ xemacs -nw
xemacs: /usr/lib/libdb-4.5.so: no version information available (required by xemacs)

The XEmacs works fine despite producing that error message. However, I want to get rid of it. Who or what do you turn to when you have problem with computer in general? Google search is your friend.

Here is the possible cause of the above problem. XEmacs require the newer version of lbdb-4.5 than the one installed on my Debian Lenny. At the time of this writing, the version of libdb4.5 on Lenny is 4.5.20-1. To fix this problem, you need to download the Sid version (4.5.20-9) and install it manually:

$ wget http://http.us.debian.org/debian/pool/main/d/db4.5/libdb4.5_4.5.20-9_i386.deb
$ sudo dpkg -i libdb4.5_4.5.20-9_i386.deb
(Reading database ... 152904 files and directories currently installed.)
Preparing to replace libdb4.5 4.5.20-1 (using libdb4.5_4.5.20-9_i386.deb) ...
Unpacking replacement libdb4.5 ...
Setting up libdb4.5 (4.5.20-9) ...

Now let’s try to run XEmacs again:

$ xemacs -nw

Voilla, no more annoying libdb-4.5.so no version information available message. Notice that you probably wouldn’t have this problem if you run Debian Sid.

Source: Meller777’s Weblog

About these ads

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: