Enable Japanese input on Debian/Ubuntu

Normally, I would install Scim and Anthy for Japanese input method on Debian. Recently, I found an easier way to achieve the same thing, which is to use IBus instead of Scim.

  1. Install ibus: sudo apt-get install ibus ibus-anthy ibus-gtk
  2. From the menu, System -> Preferences -> IBus Preference
    IBus Preference should detects that you have run IBus daemon yet, click “Yes” to run it.
  3. You’ll be asked to edit yoru .bashrc and add the following 3 lines:

    export GTK_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    export QT_IM_MODULE=ibus
  4. Click on “Input Method” tab, if you don’t see “Japanese – Anthy” listed under the Input Method list, select “Japanese -> Anthy” from the “Select an input method” drop down list, then click Add.
  5. You might want to restart X (logout and log back in)
  6. Open a text editor, and hit Ctrl + Space to toggle the Japanese input method

Reference: Japanese Input with Karmic?

Stopping hard drive clicking noise on MSI U100

Finally, the OS X has been removed from MSI Wind U100, and completely replaced by Debian (testing).

Whenever the computer is idle, the hdd makes this weird clicking noise. To stop it, we can use hdparm to turn it off.

kenno@tora:~$ sudo hdparm -B 254 /dev/sda

/dev/sda:
setting Advanced Power Management level to 0xfe (254)
APM_level = 254
kenno@tora:~$

Source: MSI Wind – Gentoo Linux Wiki

FIXED: extconf.rb:8:in `require': no such file to load — mkmf (LoadError)

While reading Linux Journal Issue 181 today, I stumbled upon a section explaining about running Ruby on Rails on Apache using an Apache module called Phusion Passenger, also known as mod_rails.

To install Passenger, I followed the instruction provided in the magazine:

sudo gem install passenger

Unxpectedly, I got the following error:

Building native extensions. This could take a while...
ERROR: Error installing passenger:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
extconf.rb:8:in `require': no such file to load -- mkmf (LoadError)
from extconf.rb:8

Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7/ext/fastthread/gem_make.out

What’s happening? What did I do wrong?

According to a blog post by Al Hoang, a Ruby dev package needed to be installed. Well, I wouldn’t have a clue about this!

So, to FIX this, I need to install ruby1.8-dev:

$ sudo apt-get install ruby1.8-dev
...

Now, I’m ready to install Passenger gem:

$ sudo gem install passenger
Building native extensions. This could take a while...
Successfully installed passenger-2.2.4
1 gem installed
Installing ri documentation for passenger-2.2.4...
Installing RDoc documentation for passenger-2.2.4...

Credit: Fixing ‘mkmf’ load error Ruby in Ubuntu

Pidgin – old version of libpurple and unknown protocol

Aaaahhh… I fixed the Pidgin problem with Unknow protocol just 5 minutes after the previous post was made. I’m going to write how I found out the problem and how it has been fixed. If you’re interested, keep reading.

In the previous post, I mentioned that I would removed the Pidgin package completely including its configuration file (# apt-get –purge remove pidgin.) I did and followed by re-installation of Pidgin, unfortunately, it didn’t fix anything.

Then I checked the About dialog (Help -> About), and I noticed the libpurple 2.5.4 under Pidgin 2.5.6. This must be the source of the problem! But I remember libpurple has been upgraded to 2.5.6 and it said so in Aptitude. So what could be possibly wrong?

Screenshot-About Pidgin

A while back, I have installed Pidgin from source code, however I was quite sure that it has been properly removed — I went into the Pidgin source and execute # make uninstall.Well, according to this Bug #385639, libpurple is still present in /usr/local/

kenno@san7:/usr/local/lib
$ ls
finch                      libpurple.so.0      pkgconfig  site_ruby
gnt                        libpurple.so.0.5.4  purple-2   xemacs
libpurple-client.so.0      perl                python2.4
libpurple-client.so.0.5.4  pidgin              python2.5
kenno@san7:/usr/local/lib

So, I need to remove these unwated libraries manually:

kenno@san7:/usr/local/lib
$ sudo rm libpurple*

Now, let’s run Pidgin again…and… that’s it. The problem has been fixed!
Screenshot-Add Account2

For the record, I have upgraded Pidgin to 2.5.8 (unstable package at the time of this post is written) and everything works as expected. Now, I’m back to a happy Pidgin user.