Pidgin – old version of libpurple and unknown protocol

Aaaahhh… I fixed the Pidgin problem with Unknow protocol just 5 minutes after the previous post was made. I’m going to write how I found out the problem and how it has been fixed. If you’re interested, keep reading.

In the previous post, I mentioned that I would removed the Pidgin package completely including its configuration file (# apt-get –purge remove pidgin.) I did and followed by re-installation of Pidgin, unfortunately, it didn’t fix anything.

Then I checked the About dialog (Help -> About), and I noticed the libpurple 2.5.4 under Pidgin 2.5.6. This must be the source of the problem! But I remember libpurple has been upgraded to 2.5.6 and it said so in Aptitude. So what could be possibly wrong?

Screenshot-About Pidgin

A while back, I have installed Pidgin from source code, however I was quite sure that it has been properly removed — I went into the Pidgin source and execute # make uninstall.Well, according to this Bug #385639, libpurple is still present in /usr/local/

$ ls
finch                  pkgconfig  site_ruby
gnt                purple-2   xemacs      perl                python2.4  pidgin              python2.5

So, I need to remove these unwated libraries manually:

$ sudo rm libpurple*

Now, let’s run Pidgin again…and… that’s it. The problem has been fixed!
Screenshot-Add Account2

For the record, I have upgraded Pidgin to 2.5.8 (unstable package at the time of this post is written) and everything works as expected. Now, I’m back to a happy Pidgin user.

One thought on “Pidgin – old version of libpurple and unknown protocol

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s